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Chapter-1: 

Fundamentals of Computers 

 

 

 

IntroducƟon to Computers 

 

What is a Computer? 

A computer is an electronic device that can store, retrieve, and process data. It performs  

tasks based on instrucƟons (soŌware) and helps in various acƟviƟes like learning,  

communicaƟon, entertainment, etc. 

 

Basic Components of Computer 



 

 

 

A computer consists of two main parts: 

1. Hardware: The physical parts of the computer that you can see and touch. 

Input Devices: Devices used to input data into the computer, like the keyboard and mouse. 

Output Devices: Devices that display the results of processing, like the monitor and printer. 

Storage Devices: Devices used to store data, like the hard drive, CD, DVD, and USB flash drive. 

CPU (Central Processing Unit): The brain of the computer that processes data and controls 
the operaƟons. 

2. SoŌware: A set of instrucƟons or programs that tell the computer how to perform specific 
tasks. 

ApplicaƟon SoŌware: Programs that help users perform specific tasks (e.g., MicrosoŌ Word, 
Paint). 



 System SoŌware: Programs that manage the computer’s hardware and allow applicaƟon 
soŌware to run (e.g., Windows, macOS). 

 

 

Types of Computers 

 1. Desktop Computer: A computer designed to be used at a desk. It has separate 
components, such as a monitor, CPU, keyboard, and mouse. 

 2. Laptop: A portable computer with a built-in screen, keyboard, and touchpad, 
designed to be used on the go. 

 3. Tablet: A small, portable touch-screen device used for a variety of tasks, including 
web browsing, watching videos, and playing games. 

 4. Smartphone: A mobile phone that can perform many tasks like a computer, such as 
accessing the Internet, sending emails, and running apps. 



 

Uses of Computers 

 • EducaƟon: Computers are used for learning and research. 

 • CommunicaƟon: Used for sending emails, chaƫng, video calls, and social media. 

 • Entertainment: Used for playing games, watching videos, and listening to music. 

 • Office Work: Used for creaƟng documents, presentaƟons, and spreadsheets. 

 • Business: Computers help in managing stock, sales, and customer details. 

 

Working of a Computer 

 1. Input: The data is entered into the computer using input devices like the keyboard 
and mouse. 

 2. Processing: The computer processes the data based on the instrucƟons from 
soŌware. 

 3. Output: AŌer processing, the result is shown on output devices like a monitor or 
printer. 

 4. Storage: Data can be saved in storage devices for future use. 



 

Basic Terminology 

 1. Data: Raw facts and figures that the computer processes. 

 2. InformaƟon: Processed data that is meaningful and useful. 

 3. Program: A set of instrucƟons wriƩen in a programming language that tells the 
computer how to perform tasks. 

 4. File: A collecƟon of data stored in a computer. 

Computer Memory 

 1. Primary Memory (RAM): Temporary memory used by the CPU to store data that is 
currently being processed. 

 2. Secondary Memory (Hard Disk): Permanent memory where files and data are stored 
for long-term access. 

 

************* 

  



Exercises 

1. Fill in the blanks: 

 1. The brain of the computer is the __________. 

 2. A __________ is a portable computer with a built-in screen and keyboard. 

 3. The primary funcƟon of a CPU is to __________ data. 

 4. __________ devices are used to enter data into the computer. 

 5. __________ is a device that stores data permanently. 

Answers: 

 1. CPU 

 2. Laptop 

 3. Process 

 4. Input 

 5. Hard Disk 

2. True or False: 

 1. A monitor is an input device. (True/False) 

 2. A laptop is a type of desktop computer. (True/False) 

 3. SoŌware helps a computer perform specific tasks. (True/False) 

 4. A hard disk is a type of primary memory. (True/False) 

 5. A printer is an output device. (True/False) 

Answers: 

 1. False 

 2. False 

 3. True 

 4. False 

 5. True 

 

3. Match the following: 

Column A  Column B 

1. CPU  a. Portable device 

2. Laptop  b. Stores data 

3. Mouse  c. Input device 



4. Hard Disk d. Brain of the computer 

5. Monitor  e. Output device 

Answers: 

1 - d 

2 - a 

3 - c 

4 - b 

5 - e 

4. Answer the following quesƟons: 

 1. What are the main components of a computer? 

 2. Name two types of soŌware. 

 3. What is the difference between hardware and soŌware? 

 4. What is the funcƟon of the CPU? 

 5. List three uses of computers. 

 

5. Short Answer QuesƟons: 

 1. What is a computer? 

 2. Name any two input devices. 

 3. What does the CPU do in a computer? 

 4. What is the funcƟon of a monitor? 

 

6. Long Answer QuesƟons: 

 1. Explain the different types of computers and describe each type. 

2. Describe the working of a computer with the steps of input, processing, output, and 
storage. 

3. What is the difference between hardware and soŌware? Explain with examples. 

4. What are the main components of a computer? Describe the funcƟon of each 
component. 
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Chapter -2 

IntroducƟon to Ubuntu 
 

What is Ubuntu? 

 

Ubuntu is a popular operaƟng system based on Linux. An operaƟng system is the soŌware that helps 
a computer run and lets you use applicaƟons like games, browsers, and more. Ubuntu is free, easy to 
use, and has a lot of features that make it perfect for beginners, students, and even professionals. 

 

Unlike other operaƟng systems like Windows or macOS, Ubuntu is open-source. This means anyone 
can download it, use it, and even change the code to improve it! Ubuntu is used by millions of people 
worldwide because it is simple, secure, and regularly updated. 

 

 

Features of Ubuntu: 
 1. User-Friendly: Ubuntu has a simple and clean interface that is easy to use for 
beginners. You don’t need advanced computer knowledge to get started. 

 2. Free to Use: Unlike some other operaƟng systems, Ubuntu is completely free. You 
don’t need to pay to install or use it. 



 3. Secure: Ubuntu is known for its security features. It is less vulnerable to viruses 
compared to other operaƟng systems. 

 4. SoŌware: Ubuntu has access to thousands of free applicaƟons that can be 
downloaded from the Ubuntu SoŌware Center. 

 5. Regular Updates: Ubuntu provides regular updates to keep your system safe and add 
new features. 

 6. Customizable: You can change the look and feel of Ubuntu to suit your needs, 
including the desktop, icons, and themes. 

 

Parts of the Ubuntu Interface: 

  Desktop: This is the main screen you see when you first open Ubuntu. It has icons for 
files, folders, and applicaƟons. 

 • Dock: Located at the boƩom of the screen, it allows you to quickly access your 
favorite applicaƟons. 

 • ApplicaƟons Menu: This is where you can find all the installed applicaƟons on your 
system. 

 • System Seƫngs: This allows you to customize and control different aspects of 
Ubuntu like screen brightness, sound seƫngs, and more. 

How to Install Ubuntu? 
 1. Download Ubuntu: First, go to the official Ubuntu website and download the latest 
version. 

 2. Create a Bootable USB: You can create a bootable USB drive to install Ubuntu on 
your computer. There are tools available like Rufus to make this process easy. 

 3. Install Ubuntu: Restart your computer and boot from the USB drive. Follow the on-
screen instrucƟons to install Ubuntu. 

Why Use Ubuntu? 
 1. It’s Free: You don’t have to pay for Ubuntu. You can download it and start using it 
right away. 

 2. Easy to Use: Ubuntu is easy to use, even for people who have never used a computer 
before. 

 3. Open Source: This means you can see how Ubuntu works, and even contribute to 
making it beƩer. 

 4. Secure: Ubuntu is very safe and secure. It’s less likely to get viruses and other 
harmful programs. 

 5. Great for Learning: If you want to learn more about computers and how they work, 
Ubuntu is a good operaƟng system to start with. 

***************** 



Exercises – 2 

 

1. Fill in the blanks: 

 1. Ubuntu is an __________ operaƟng system. 

 2. Ubuntu is known for being __________ to use. 

 3. The main screen in Ubuntu is called the __________. 

 4. Ubuntu is __________ to use, meaning you don’t have to pay for it. 

 5. The applicaƟons you use in Ubuntu are found in the __________ menu. 

Answers: 

 1. open-source 

 2. easy 

 3. Desktop 

 4. free 

 5. ApplicaƟons 

 

2. True or False: 

 1. Ubuntu is a paid operaƟng system. (True/False) 

 2. Ubuntu is only for advanced users. (True/False) 

 3. Ubuntu is an open-source operaƟng system. (True/False) 

 4. You can install Ubuntu using a USB drive. (True/False) 

5. Ubuntu is known for being less secure than other operaƟng systems. (True/False) 

Answers: 

 1. False 

 2. False 

 3. True 

 4. True 

 5. False 

 

3. Match the following: 

 

Column A    Column B 



1. Ubuntu    a. Easy to use 

2. Free operaƟng system  b. Open-source 

3. ApplicaƟons Menu  c. Place to find all your installed apps 

4. Ubuntu SoŌware Center  d. Free to use 

Answers: 

1 - b 

2 - d 

3 - c 

4 - a 

4. Short Answer QuesƟons (4): 

 1. What is Ubuntu? 

 2. Name any two features of Ubuntu. 

 3. Why is Ubuntu considered a secure operaƟng system? 

 4. How can you install Ubuntu on a computer? 

5. Long Answer QuesƟons: 

 1. Explain the key features of Ubuntu. 

 2. How can you customize Ubuntu according to your preferences? 

 3. Why is Ubuntu a good choice for beginners? 

 4. Describe the steps to install Ubuntu on your computer. 

************* 
  



 

Chapter - 3 

IntroducƟon to LibreOffice Writer 
 

What is LibreOffice Writer? 
LibreOffice Writer is the word processing tool of the LibreOffice suite. It is used for creaƟng, ediƟng, 
and formaƫng text documents such as leƩers, reports, essays, and stories. It works similar to other 
word processing soŌware like MicrosoŌ Word but is free to use. 

 

With LibreOffice Writer, you can type and edit text, insert pictures, create tables, and format your 
document with different fonts, colors, and styles. It also allows you to save and print your work, 
making it a powerful tool for students, teachers, and professionals. 

 

 

 

Basic Features of LibreOffice Writer 
 1. Text Formaƫng: 



You can change the font style, size, and color of the text. You can also make the text bold, italic, 
underline, or strikethrough. 

 2. Paragraph Formaƫng: 

You can adjust the alignment (leŌ, right, center, jusƟfy), set the line spacing, and use bullets or 
numbering for lists. 

 3. InserƟng Images and Tables: 

LibreOffice Writer allows you to insert images, shapes, and tables into your documents. You can 
resize and move them around as needed. 

 4. Spelling and Grammar Check: 

Writer automaƟcally checks your spelling and grammar while you type. It underlines mistakes and 
suggests correcƟons. 

 5. Headers and Footers: 

You can add headers (top of the page) and footers (boƩom of the page) to your document, which is 
useful for adding page numbers or document Ɵtles. 

 6. Page Setup: 

You can change the margins, page size, and orientaƟon (portrait or landscape) according to your 
requirements. 

 7. Saving and PrinƟng: 

LibreOffice Writer allows you to save your work in various formats, including .odt (the default 
format), .docx, .pdf, and more. You can also print documents directly from the soŌware. 

How to Create a Document in LibreOffice Writer 

 1. Open LibreOffice Writer: Click on the LibreOffice Writer icon to launch the program. 

 2. Type Your Text: Start typing your text. You can use the keyboard to input your 
content. 

 3. Format Your Document: Use the toolbar at the top to change the font, size, color, 
and alignment of your text. You can also add images or tables using the menu opƟons. 

 4. Save Your Document: Click File > Save to save your document. You can choose the 
locaƟon on your computer where you want to store it. 

 5. Print Your Document: If you want to print your document, click File > Print. 

 

Why Use LibreOffice Writer? 
 1. Free and Open-Source: LibreOffice Writer is completely free, unlike many word 
processors that require a paid license. 

 2. Easy to Use: The interface is simple and user-friendly, making it easy for students to 
create and format documents. 



 3. CompaƟbility: LibreOffice Writer can open and save documents in different formats 
like .docx, .odt, and .pdf. 

 4. No Need for Internet: Unlike some word processing tools, LibreOffice Writer doesn’t 
require an internet connecƟon to work, making it great for offline use. 

 5. Regular Updates: LibreOffice Writer is updated regularly, so you get new features 
and improvements. 

 

************************** 

Exercises - 3 
 

1. Fill in the blanks: 
 1. LibreOffice Writer is used for __________ and ediƟng text documents. 

 2. You can change the __________ and size of the text in LibreOffice Writer. 

 3. To check spelling in LibreOffice Writer, the program underlines the mistakes with a 
__________ line. 

 4. To add images to your document, click on the __________ menu. 

 5. You can save your document in the __________ format. 

Answers: 

 1. CreaƟng 

 2. Font 

 3. Red 

 4. Insert 

 5. .odt 

 

2. True or False: 
 1. LibreOffice Writer is a free word processor. (True/False) 
           2. You cannot insert images into a document in LibreOffice Writer. (True/False) 

3. LibreOffice Writer automaƟcally checks for spelling and grammar mistakes. 
(True/False) 

 4. You can only save your document in the .docx format. (True/False) 
5.        You can change the page orientaƟon to landscape in LibreOffice Writer. 
           (True/False) 
Answers: 

 1. True 

 2. False 

 3. True 



 4. False 

 5. True 

 

3. Match the following: 
Column A    Column B 

1. LibreOffice Writer   a. To check your spelling and grammar 

2. Insert Menu   b. Allows you to change text fonts, sizes, and colors 

3. Spelling and Grammar Check c. You can insert images, tables, and shapes 

4. Formaƫng Toolbar  d. A free word processing soŌware 

 

Answers: 

1 - d 

2 - c 

3 - a 

4 - b 

 

4. Short Answer QuesƟons (4): 
 1. What is LibreOffice Writer used for? 

 2. How can you change the font style in LibreOffice Writer? 

 3. What are the benefits of using LibreOffice Writer? 

 4. How can you insert an image into a document in LibreOffice Writer? 

5. Long Answer QuesƟons (4): 
 1. Explain the features of LibreOffice Writer. 

 2. Describe the process of creaƟng a document in LibreOffice Writer, from opening the 
soŌware to saving the file. 

 3. How can you format text in LibreOffice Writer? Give examples of text formaƫng 
opƟons available. 

 4. Why is LibreOffice Writer a good choice for students? Explain in detail 

 

******************** 

  



 

Chapter - 4: 

EdiƟng and Formaƫng in LibreOffice Writer 
 

What is EdiƟng and Formaƫng in LibreOffice Writer? 
In LibreOffice Writer, ediƟng refers to changing the content of a document, such as adding or 
deleƟng text, while formaƫng involves changing the appearance of the document, like adjusƟng the 
font style, size, and alignment. Both ediƟng and formaƫng are important skills to make your 
documents look neat, professional, and easy to read. 

EdiƟng in LibreOffice Writer 
 1. SelecƟng Text: 

 • To edit text, you first need to select it. To select a word, click on it. To select a 
sentence or paragraph, click and drag your mouse over the text. 

 • You can also use the keyboard. Hold down the ShiŌ key and use the arrow keys to 
select text. 

 2. DeleƟng Text: 

 • To delete text, simply highlight it and press the Delete key or the Backspace key on 
your keyboard. 

 3. Adding Text: 

 • To add new text, place the cursor where you want to insert the text and start typing. 

 4. Cut, Copy, and Paste: 

 • Cut: Use Ctrl + X (Windows) or Command + X (Mac) to remove selected text and 
store it in the clipboard. 

 • Copy: Use Ctrl + C (Windows) or Command + C (Mac) to copy selected text. 

 • Paste: Use Ctrl + V (Windows) or Command + V (Mac) to paste the copied or cut text 
in a new locaƟon. 



 

Formaƫng in LibreOffice Writer 
 1. Font Formaƫng: 

 • Font Style: Change the font type (e.g., Times New Roman, Arial) from the  

Font menu. 

 • Font Size: Increase or decrease the size of the text using the Font Size  

drop-down list. 

• Font Color: You can change the color of the text using the Text Color  

buƩon on the toolbar. 

 • Bold, Italic, and Underline: Highlight the text and click on the Bold, Italic, or  

Underline buƩon to apply these styles. 

 

 2. Paragraph Formaƫng: 

 • Alignment: Align text to the leŌ, center, right, or jusƟfy it (distribute evenly  

across the page) using the alignment buƩons in the toolbar. 

 • Line Spacing: Adjust the spacing between lines of text for beƩer  

readability. 



 • IndentaƟon: Change the leŌ or right indentaƟon to move text away from  

the page’s edge. 

 • Bullets and Numbering: Create bulleted or numbered lists by clicking the  

Bullets or Numbering buƩon. 

 3. Changing Page Layout: 

 • Margins: Adjust the space between the edges of the page and your text.  

You can do this by going to Format > Page and selecƟng Margins. 

 • Page OrientaƟon: Change the page layout from Portrait (verƟcal) to  

Landscape (horizontal) by going to Format > Page. 

 4. Headers and Footers: 

 • You can add headers (at the top of the page) and footers (at the boƩom of  

the page) by going to Insert > Header and Footer. 

 5. InserƟng Images: 

 • To insert an image into your document, click on Insert > Image and select  

the image you want to add. You can resize the image by dragging the  

corners. 

 

Why is Formaƫng Important in LibreOffice Writer? 

Formaƫng helps to make your document more organized, clear, and visually appealing. It also helps 
to emphasize important informaƟon, such as headings or key points, making it easier for the reader 
to follow and understand your content. 

***************************** 

 

Exercises - 4 

1. Fill in the blanks: 

 1. To make text bold in LibreOffice Writer, click the __________ buƩon. 

 2. To copy text, use the shortcut __________. 

 3. You can change the size of the font using the __________ menu. 

 4. To insert an image, click on the __________ menu. 

 5. To change the page orientaƟon to landscape, go to __________   

                       __________. 

Answers: 



 1. Bold 

 2. Ctrl + C 

 3. Font Size 

 4. Insert 

 5. Format > Page 

2. True or False: 

 1. You can change the font style in LibreOffice Writer. (True/False) 

 2. To paste text, use the shortcut Ctrl + P. (True/False) 

3. LibreOffice Writer allows you to insert images into your document. (True/False) 

4. Paragraph formaƫng includes changing the alignment and line spacing. (True/False) 

5. You can only create numbered lists, not bulleted lists, in LibreOffice Writer. 
(True/False) 

Answers: 

 1. True 

 2. False 

 3. True 

 4. True 

 5. False 

 

3. Match the following: 

Column A    Column B 

1. Bold   a. Changes the font size 

2. Page OrientaƟon  b. Adds an image to the document 

3. Copy Text   c. Makes text appear darker 

4. Insert Menu  d. Allows you to change the layout of the page 

5. Font Size   e. Ctrl + C 

Answers: 

1 - c 

2 - d 

3 - e 

4 - b 

5 - a 



 

4. Short Answer QuesƟons (4): 

 

 1. How do you change the font style in LibreOffice Writer? 

 2. What is the purpose of the Bullets and Numbering features in LibreOffice  

Writer? 

 3. What is the shortcut for copying text in LibreOffice Writer? 

 4. How can you insert an image into a document in LibreOffice Writer? 

 

 

5. Long Answer QuesƟons (4): 

 1. Describe the steps to format text in LibreOffice Writer, including font style, size and 
color. 

 2. Explain the importance of paragraph formaƫng. How can you change alignment, line 
spacing, and indentaƟon in LibreOffice Writer? 

 3. What is the role of headers and footers in a document? How can you add them in 
LibreOffice Writer? 

 4. How can you change the page layout, such as margins and page orientaƟon, in 
LibreOffice Writer? 

 

************************ 

 

  



 

Chapter - 5  

IntroducƟon to LibreOffice Impress 
 

 

What is LibreOffice Impress? 

LibreOffice Impress is a presentaƟon soŌware in the LibreOffice suite used to create slideshows for 
presenƟng informaƟon in a fun and engaging way. Whether you are presenƟng a school project, a 
report, or any other topic, LibreOffice Impress helps you display your ideas visually. 

Similar to MicrosoŌ PowerPoint, Impress allows you to create a series of slides that can contain text, 
images, sounds, videos, charts, and more. You can add special effects, animaƟons, and transiƟons to 
make your presentaƟon more interesƟng and dynamic. 

 

 

Features of LibreOffice Impress 

 

 1. CreaƟng Slides: 



 • You can create mulƟple slides in a single presentaƟon. Each slide can have a different 
layout (e.g., Ɵtle slide, bullet points, images) depending on the content you want to show. 

 2. Text Formaƫng: 

 • Just like in a word processor, you can format text in LibreOffice Impress by changing 
the font, size, color, and style (bold, italics, underline). 

 3. InserƟng Images and Shapes: 

 • You can add pictures from your computer, as well as shapes like circles, arrows, 
squares, and lines to your slides. These can help you highlight or explain key ideas. 

 4. Slide TransiƟons: 

 • Slide transiƟons are animaƟons that occur when you move from one slide to the 
next during the presentaƟon. For example, you can have a slide fade into the next one or fly from the 
side. 

 5. AnimaƟons: 

 • You can apply animaƟons to objects like text, images, or shapes on a slide. This 
makes them appear, disappear, or move in a fun way when you show the slide. 

 6. Themes and Backgrounds: 

 • Impress offers pre-designed themes and backgrounds that make your presentaƟon 
look professional. You can choose the design that suits your topic and style. 

 7. InserƟng Audio and Video: 

 • You can add audio clips or video files to your presentaƟon. This can make your 
presentaƟon more interacƟve and interesƟng, especially when explaining complex ideas. 

 

 

 8. Slideshow View: 

 • When you are ready to present your work, you can switch to Slideshow View, where 
your slides will be shown one aŌer another, and you can control the Ɵming and transiƟons. 

 

Why Should You Use LibreOffice Impress? 
 1. Free and Open-Source: 

LibreOffice Impress is completely free, and you can download and use it without any cost. It is also 
open-source, meaning anyone can modify and improve the soŌware. 

 2. Easy to Use: 

Impress has a simple and user-friendly interface, making it easy for students and beginners to create 
and design presentaƟons without needing special skills. 

 3. MulƟmedia Support: 



You can add text, pictures, audio, and videos, making your presentaƟon more engaging and effecƟve 
for sharing your ideas. 

 4. Cross-Plaƞorm: 

LibreOffice works on Windows, macOS, and Linux, so you can use Impress on almost any computer. 

 5. CompaƟbility: 

LibreOffice Impress can open and save presentaƟons in formats like .pptx (MicrosoŌ PowerPoint) and 
.pdf, allowing you to share your presentaƟons easily with others. 

 

How to Create a PresentaƟon in LibreOffice Impress 
 1. Open LibreOffice Impress: 

When you open Impress, a blank presentaƟon opens. You can choose a pre-designed theme to give 
your presentaƟon a professional look. 

 2. Add Slides: 

To add more slides, click Insert > Slide. You can select the layout for the new slide (e.g., Ɵtle slide, 
blank slide, or text slide). 

 

 3. Add Text: 

Click on the text box to type your text. You can change the font, size, and color by using the 
formaƫng opƟons in the toolbar. 

 4. Insert Images and Shapes: 

To insert an image, click on Insert > Image. To add a shape, click on Insert > Shape and choose from 
various opƟons like circles, rectangles, and arrows. 

 5. Apply TransiƟons: 

To add a transiƟon, go to the Slide menu and select Slide TransiƟon. Choose from various effects like 
Fade, Wipe, or Push to apply between slides. 

 6. Add AnimaƟons: 

Select an object (text or image) on a slide, then go to Slide Show > Custom AnimaƟon to apply an 
animaƟon effect (e.g., making text appear with a bounce). 

 7. View the PresentaƟon: 

When you are ready, click on Slide Show > Start from Beginning to view your presentaƟon as a 
slideshow. 

 8. Save the PresentaƟon: 

Click on File > Save to save your work. You can choose from different formats like .odp (LibreOffice’s 
default) or .pptx (PowerPoint format). 

 

************************* 



Exercises - 5 
1. Fill in the blanks: 
 1. LibreOffice Impress is used to create __________. 

 2. To add a new slide in LibreOffice Impress, click on __________. 

 3. You can apply __________ to make objects like text and images appear  

or disappear in your presentaƟon. 

4. To change the background design of your presentaƟon, you can choose a 
__________. 

5. LibreOffice Impress allows you to add __________ and __________ to make your 
presentaƟon more engaging. 

 

Answers: 

 1. PresentaƟons 

 2. Insert > Slide 

 3. AnimaƟons 

 4. Theme 

 5. Audio and Video 

 

2. True or False: 
 1. You cannot add animaƟons to text in LibreOffice Impress. (True/False) 

 2. LibreOffice Impress allows you to insert videos and images. (True/False) 

 3. Slide transiƟons are used to make objects move on a slide. (True/False) 

 4. You can save your presentaƟon in the .pptx format. (True/False) 

 5. LibreOffice Impress is a paid soŌware. (True/False) 

 

 

 

Answers: 

 1. False 

 2. True 

 3. False 

 4. True 



 5. False 

3. Match the following: 
Column A    Column B 

1. LibreOffice Impress  a. Used to add effects between slides 

2. AnimaƟons   b. Free presentaƟon soŌware 

3. Slide TransiƟons   c. Making objects appear or disappear 

4. Insert Menu   d. Used to add pictures, videos, and shapes 

5. Save Your PresentaƟon  e. File > Save 

Answers: 

1 - b 

2 - c 

3 - a 

4 - d 

5 - e 

 

4. Short Answer QuesƟons (4): 
 1. What is LibreOffice Impress used for? 

 2. How do you add a new slide in LibreOffice Impress? 

 3. What is the purpose of slide transiƟons in LibreOffice Impress? 

 4. How can you insert an image into a slide in LibreOffice Impress? 

 

5. Long Answer QuesƟons (4): 
1. Explain the steps involved in creaƟng a presentaƟon in LibreOffice Impress, from 

adding slides to inserƟng text and images. 

2. What are animaƟons and transiƟons in LibreOffice Impress? How do they help make 
a presentaƟon more interesƟng? 

3. Why is LibreOffice Impress a good choice for students to create presentaƟons? 
Explain its features. 

4. Describe how to save and view your presentaƟon in LibreOffice Impress. What 
opƟons are available when saving your presentaƟon? 

 

********************************* 

  



Chapter - 6 

CreaƟng Slides in LibreOffice Impress 
 

IntroducƟon 

 

In LibreOffice Impress, creaƟng slides is the first step in making a presentaƟon. Each slide can contain 
text, images, charts, shapes, and more. You can add mulƟple slides and customize each one 
according to your needs. In this chapter, we will learn how to create slides, add new slides, change 
layouts, and more. 

 

How to Create Slides in LibreOffice Impress? 

 

 1. Opening LibreOffice Impress: 

 • To start creaƟng a presentaƟon, first, you need to open LibreOffice Impress. You can 
do this by clicking on the Impress icon in the LibreOffice suite or by selecƟng File > New > 
PresentaƟon. 

 2. Adding New Slides: 

 • When you open a new presentaƟon, one slide will be created automaƟcally (usually 
a Ɵtle slide). To add more slides: 

 • Go to the Menu: Click Insert > Slide. 

 • Use Keyboard Shortcut: Press Ctrl + M to add a new slide. 

 3. Changing the Layout of a Slide: 

 • Every slide can have a different layout, depending on the content you want to add. 
For example, you can choose a Title Slide, Text Slide, or a Picture Slide. 

 • To change the layout of a slide: 

 • Right-click on the slide in the leŌ panel and select Slide Layout. A list of available 
layouts will appear. Choose the one that fits your content. 

 4. Adding Content to Slides: 

 • AŌer adding a slide, click inside the text box to add text. You can also insert images 
by clicking on Insert > Image, and shapes by selecƟng Insert > Shape. 

 • To format the text, use the opƟons in the toolbar to change the font, size, color, and 
alignment. 

 

Slide Show 



 1. StarƟng the Slide Show: 

 • AŌer creaƟng your slides, you can present them as a slideshow. To start the 
slideshow: 

 • Click on Slide Show in the menu and select Start from Beginning, or 

 • Press F5 on your keyboard. 

 2. NavigaƟng Through the Slideshow: 

 • You can move to the next slide by pressing the Right Arrow key or clicking the 
mouse. 

 • To go back to the previous slide, use the LeŌ Arrow key or right-click to select 
Previous Slide. 

 3. ExiƟng the Slideshow: 

 • To exit the slideshow and return to the ediƟng view, press Esc on the keyboard. 

 

CreaƟng a PresentaƟon 
 1. Adding MulƟple Slides: 

 • Click Insert > Slide to add as many slides as you need. 

 • For each new slide, choose the appropriate layout (e.g., Title Slide, Text Slide, Picture 
Slide). 

 2. Customizing the PresentaƟon: 

 • You can change the background, apply themes, and add animaƟons to your text and 
images for beƩer visual appeal. 

 • Add transiƟons between slides by going to Slide > Slide TransiƟon and selecƟng a 
transiƟon effect like Fade, Wipe, or Push. 

Saving PresentaƟons 
 1. Saving a New PresentaƟon: 

 • To save your presentaƟon, click File > Save or Ctrl + S. 

 • Choose a locaƟon on your computer to save the file and give it a name. The default 
file format is .odp (OpenDocument PresentaƟon). 

 2. Saving the PresentaƟon as a PowerPoint File: 

 • If you want to save the presentaƟon in MicrosoŌ PowerPoint format, click File > Save 
As, and choose PowerPoint (.pptx) as the file type. 

 3. Saving the PresentaƟon as PDF: 

 • If you want to save your presentaƟon as a PDF file (for prinƟng or sharing), go to File 
> Export As > Export as PDF. 

Opening Saved PresentaƟons 



 1. Opening a Saved PresentaƟon: 

 • To open an exisƟng presentaƟon, click File > Open and choose the file from your 
computer. 

 • You can also open presentaƟons saved in other formats like .pptx (PowerPoint 
format). 

 2. EdiƟng an Opened PresentaƟon: 

 • Once opened, you can conƟnue ediƟng the presentaƟon by adding or deleƟng slides, 
changing text, inserƟng images, etc. 

ExiƟng LibreOffice Impress 
 1. ExiƟng the ApplicaƟon: 

 • When you are finished working on your presentaƟon, you can exit LibreOffice 
Impress by clicking File > Exit or simply closing the program window. 

 2. Saving Before ExiƟng: 

 • If you haven’t saved your work, Impress will ask you to save the presentaƟon before 
exiƟng. Click Yes to save your changes, or No if you do not want to save. 

******************************* 

Exercises - 6 
 

1. Fill in the blanks: 

 1. To add a new slide in LibreOffice Impress, click __________ > Slide. 

2. To change the layout of a slide, right-click on the slide and choose __________. 

 3. To start a slideshow, click __________ > Start from Beginning. 

4. To save your presentaƟon in PowerPoint format, choose __________ from the Save 
As opƟons. 

 5. To exit the slideshow, press the __________ key. 

 

Answers: 

 1. Insert 

 2. Slide Layout 

 3. Slide Show 

 4. PowerPoint (.pptx) 

 5. Esc 

2. True or False: 



1. You can only add one slide to a presentaƟon in LibreOffice Impress. (True/False) 

2. To change the background design, you need to go to the View menu. (True/False) 

 3. You can save your presentaƟon as a PDF. (True/False) 

4. You can add images and shapes to your slides in LibreOffice Impress. (True/False) 

 5. Pressing Esc exits the presentaƟon mode. (True/False) 

 

 

 

Answers: 

 1. False 

 2. False 

 3. True 

 4. True 

 5. True 

 

3. Match the following: 

 

Column A      Column B 

1. Insert > Slide    a. Use this to start the presentaƟon 

2. Save     b. Used to add a new slide 

3. Slide Show > Start from Beginning c. Used to save your work 

4. Right-click on the slide   d. Opens opƟons to change layout 

5. PowerPoint (.pptx)   e. Save the presentaƟon as PowerPoint format 

 

Answers: 

 

1 - b 

2 - c 

3 - a 

4 - d 

5 – e 

 



4. Short Answer QuesƟons (4): 
 1. How can you add a new slide to your presentaƟon in LibreOffice Impress? 

 2. What is the shortcut to start a slideshow in LibreOffice Impress? 

 3. How do you save a presentaƟon in LibreOffice Impress? 

 4. What can you do to change the layout of a slide? 

 

5. Long Answer QuesƟons (4): 
 1. Explain the steps to create a presentaƟon in LibreOffice Impress. Include how to add 
slides, change layouts, and add content. 

 2. Describe the process of saving a presentaƟon in different formats, such as .odp, 
.pptx, and .pdf. 

 3. What are the benefits of using slide transiƟons and animaƟons in a presentaƟon? 
How do they make a presentaƟon more engaging? 

 4. Explain how to exit LibreOffice Impress safely, and what happens if you try to exit 
without saving your work. 

 

**************************** 

  



Chapter – 7 

The Internet 
 

What is the Internet? 

• The Internet is a global network of connected computers that allows people to share 
informaƟon and communicate with each other from anywhere in the world. 

• It allows you to access websites, send emails, chat with others, and much more. 

 
 

 

Uses of the Internet 

 

 1. Searching InformaƟon: You can find almost any informaƟon you need on the 
Internet using search engines like Google. 

 



 2. CommunicaƟon: You can send emails, chat with friends, or even talk using video 
calling apps like Zoom, Skype, etc. 

 

 3. Entertainment: Watch videos, play games, listen to music, or explore different types 
of entertainment online. 

 

 4. Learning: There are educaƟonal websites, videos, and resources to help students 
learn new things. 

 

 5. Shopping: You can buy things online through e-commerce websites. 

 

 

 



 

 

 

 

 

 

 

How does the Internet Work? 
• The Internet uses a system of networks to connect computers to each other. 

• It requires a device (like a computer, smartphone, or tablet) and an Internet 
connecƟon (usually through a service provider). 

 

 



 

 

Important Terms 

 1. Website: A collecƟon of pages on the Internet that can include text, images, and 
videos. 

 2. Search Engine: A tool to find informaƟon on the Internet. Example: Google, Bing. 

 3. Browser: A soŌware used to access websites. Example: Google Chrome, Safari. 

 4. URL (Uniform Resource Locator): The address of a website (e.g., www.google.com). 

 5. Wi-Fi: Wireless Internet connecƟon. 

 

Safety on the Internet 
 • Privacy: Don’t share personal informaƟon like your address, phone number, or 
passwords online. 

 • Cyberbullying: Be kind to others online. If someone is bullying you, talk to an adult. 

 • Stranger Danger: Never chat with strangers or agree to meet them in person. 

 • Secure Websites: Always check for a “lock” symbol on websites to ensure they are 
safe to use. 

 

Accessing the Internet 
 • To connect to the Internet, you need a device and an Internet connecƟon. You can 
either use a mobile data connecƟon or connect to Wi-Fi. 

 • Once connected, you can open a browser (like Chrome or Safari) and search for 
websites or online content. 

 

 

********************************* 

 

Exercise – 7 
1. Fill in the blanks: 
a) The Internet is a global network of __________. 

b) You can search for informaƟon on the Internet using a __________. 

c) A __________ helps you access websites on the Internet. 



d) Websites can be accessed using a __________. 

Answers: 

a) computers 

b) search engine 

c) browser 

d) URL 

 

2. True or False: 

 

a) The Internet is only used for communicaƟon. (True/False) 

b) A browser helps you search for informaƟon. (True/False) 

c) It’s safe to share your password with strangers online. (True/False) 

d) You can watch videos and play games on the Internet. (True/False) 

 

Answers: 

a) False 

b) False 

c) False 

d) True 

 

 

3. Match the following: 

Column A    Column B 

1. Website    a. Browsing the Internet 

2. Search Engine   b. A collecƟon of pages 

3. Browser    c. Google, Bing 

4. URL    d. The address of a website 

 

Answers: 

1 - b 

2 - c 

3 - a 



4 - d 

 

4. Answer the following quesƟons: 

a) What is the Internet? 

b) MenƟon any two uses of the Internet. 

c) What are the main components needed to access the Internet? 

d) How can you stay safe while using the Internet? 

 

Answers: 

a) The Internet is a global network of connected computers that allows people to share informaƟon 
and communicate with each other. 

b) Two uses of the Internet: 

 1. Searching for informaƟon. 

 2. CommunicaƟng through emails or chat. 

c) To access the Internet, you need a device (like a computer or smartphone) and an Internet 
connecƟon (Wi-Fi or mobile data). 

d) To stay safe on the Internet: 

 • Never share personal informaƟon. 

 • Be kind and respecƞul to others online. 

 • Only use secure websites (check for the lock symbol). 

Project Work 
 • Create a list of websites you visit regularly. Write down the purpose of each website 
and how it helps you. 

 • Draw a simple diagram showing how a computer connects to the Internet (you can 
include a computer, router, and Wi-Fi symbol). 

This chapter introduces students to the Internet and its uses while emphasizing safety and 
responsible usage. If you need more details or examples for any of these secƟons, feel free to ask! 

[04/02, 11:06 am] Palak Ma'am Aloysius school: Sure! Here are the quesƟons: 

 

5. Short Answer QuesƟons: 
 1. What is the Internet? 

 2. MenƟon two uses of the Internet. 

 3. What is a browser? 



 4. What does URL stand for? 

 5. How can you stay safe on the Internet? 

6. Long Answer QuesƟons: 

 1. What is the Internet, and how does it work? 

 2. What are the main components needed to access the Internet? 

 3. Explain how you can stay safe while using the Internet. 

 4. How does a search engine help you on the Internet? 

***************************** 

  



 

Chapter- 8 

Internet Safety, NeƟqueƩe, Cyber Crime, Emojis, and 
Social Networking 

IntroducƟon 

 

The internet is a wonderful place to learn, play, and communicate with others. However, just like in 
the real world, it is important to follow certain rules to stay safe and respecƞul. This chapter will 
introduce you to neƟqueƩe, explain what cybercrime is, discuss the use of emojis, and explain social 
networking. It will also help you understand how to safely use the internet and why it is important to 
follow these guidelines. 

 

NeƟqueƩe (Internet EƟqueƩe) 

 

NeƟqueƩe is a set of rules or guidelines for good behavior when using the internet. It helps to ensure 
that everyone is respecƞul and follows common courtesy while communicaƟng online. Just like in 
the real world, how you treat others online is important. 

 

Key NeƟqueƩe Rules: 
 1. Be Kind and Respecƞul: 

• Always be polite when talking to others online, just like you would in real life. 

 • Avoid using hurƞul language or saying things that can upset others. 

 2. Think Before You Post: 

• Once you post something online, it can be seen by anyone. Always think carefully 
before posƟng photos, comments, or messages. 

 3. Respect Privacy: 

• Never share someone else’s personal informaƟon without their permission. Respect 
other people’s privacy and never post their pictures without asking. 

 4. Avoid ShouƟng: 

• ShouƟng online means typing in capital leƩers, and it’s considered rude. Always use 
normal leƩer cases. 

 5. Use Proper Language: 

 • Use good language and avoid using slang or offensive words. 



Example: 

If you want to ask a friend for help in an online game, you could say: 

“Hi, can you help me with this level? I’m having trouble. Thanks!” 

 

Cyber Crime 

 

Cybercrime is any criminal acƟvity that happens on the internet. It involves the use of 
computers, smartphones, and other devices to commit illegal acƟviƟes. These crimes can be 
harmful to individuals, companies, or governments. 

 

Types of Cyber Crime: 

 1. IdenƟty TheŌ: 

• This happens when someone steals your personal informaƟon (like your name, 
address, or password) to impersonate you or commit fraud. 

 2. Cyberbullying: 

• This is when someone uses the internet to hurt or inƟmidate another person, either 
through social media, emails, or messaging. 

 3. Hacking: 

• This happens when someone illegally breaks into a website or computer to steal 
informaƟon or cause damage. 

 

 4. Phishing: 

• Phishing is when someone pretends to be a trustworthy organizaƟon (like a bank) to 
trick you into giving away your personal informaƟon, like passwords or credit card 
numbers. 

 

How to Stay Safe: 
 • Never share your passwords or personal details online. 

 • Avoid opening suspicious emails or links that might look like scams. 

• Tell an adult if you encounter any form of cyberbullying or suspicious acƟvity online. 

Emojis 
Emojis are small pictures or symbols used to express emoƟons, feelings, or ideas in text 
messages, emails, or social media posts. Emojis help make online conversaƟons more fun 
and understandable. 



 

Popular Emojis: 

 • 😊 (Smiling Face) – Used to show happiness or friendliness. 

 • 😢 (Crying Face) – Used to show sadness. 

• 😎 (Smiling Face with Sunglasses) – Used to show confidence or coolness. 

 • ❤ (Red Heart) – Used to show love or affecƟon. 

 

How to Use Emojis Properly: 
• Use emojis to express feelings but avoid using them in serious conversaƟons where 

clear words are needed. 

 • Don’t overuse emojis in professional or important messages. 

Emojis make communicaƟon fun but remember not to use them to replace 
meaningful words, especially in important or formal situaƟons. 

Social Networking 

 

Social networking is a way of connecƟng with people on the internet. Websites like Facebook, 
Instagram, TwiƩer, and Snapchat allow people to create profiles, share informaƟon, and 
communicate with each other. 

How Social Networking Works: 
 • People create profiles with their personal informaƟon and pictures. 

• They can follow or friend other people to see updates, pictures, and posts from their 
friends and family. 

 • You can post photos, share videos, or send messages to others. 

How to Stay Safe on Social Media: 
 1. Don’t Share Personal InformaƟon: 

Avoid posƟng your home address, phone number, or other private details online. 

 2. Adjust Privacy Seƫngs: 

Make sure your social media accounts are private so only your friends can see your posts. 

 3. Be Careful About Who You Accept as a Friend: 

Only accept friend requests from people you know in real life. 

 4. Talk to an Adult: 

If you ever feel uncomfortable or unsafe on social media, always talk to a trusted adult. 



Summary: 
 • NeƟqueƩe teaches you how to behave kindly and respecƞully online. 

• Cybercrime is any illegal acƟvity done using the internet, and you should always stay 
alert and protect your personal informaƟon. 

 • Emojis help express emoƟons online but should be used wisely. 

• Social networking allows you to connect with others, but it’s important to protect 
your privacy and be careful with what you share online. 

**************************** 

Exercises – 8 

 
1. Fill in the blanks: 
 1. NeƟqueƩe refers to the rules of _________ behavior on the internet. 

 2. Cybercrime involves ________ acƟviƟes carried out online. 

3. ________ is a type of cybercrime where someone steals your personal informaƟon. 

 4. Emojis are used to express ________ and ________ in messages. 

5. When using social media, you should keep your accounts ________ to protect your 
privacy. 

 

Answers: 

 1. Good 

 2. Illegal 

 3. IdenƟty theŌ 

 4. EmoƟons, feelings 

 5. Private 

 

2. True or False: 

 1. Cyberbullying is a type of cybercrime. (True/False) 

2. You should share your password with your friends to keep them safe. (True/False) 

3. It’s okay to post your home address on social media if it’s just for friends. 
(True/False) 

 4. Emojis should be used in professional emails. (True/False) 

 5. It’s important to think before posƟng something online. (True/False) 



 

Answers: 

 1. True 

 2. False 

 3. False 

 4. False 

 5. True 

 

3. Match the following: 
Column A   Column B 

1. NeƟqueƩe   a. Use to show love or happiness 

2. Cyber Crime  b. Use emojis to express feelings 

3. Emojis   c. Be polite and respecƞul online 

4. Social Networking d. AcƟviƟes that are illegal online 

5. Privacy Seƫngs  e. Keep your social media profile private 

Answers: 

1 - c 

2 - d 

3 - b 

4 - e 

5 - e 

4. Short Answer QuesƟons (4): 

 1. What is neƟqueƩe, and why is it important? 

 2. Name two types of cybercrimes. 

 3. What are emojis used for in online communicaƟon? 

 4. How can you stay safe while using social networking sites? 

 

5. Long Answer QuesƟons (4): 
 1. Explain the importance of neƟqueƩe when using the internet. Give some examples 
of good neƟqueƩe. 

 2. What is cybercrime? Describe at least two types of cybercrime and explain how you 
can protect yourself from them. 



 3. Describe how to use emojis properly. What are the benefits and limitaƟons of using 
emojis in online communicaƟon? 

 4. Explain social networking. What should you keep in mind while using social media to 
ensure your safety? 

 

Conclusion 

In today’s world, the internet is a great place to learn and communicate, but it’s also important to 
follow the rules of neƟqueƩe, be aware of cybercrimes, use emojis wisely, and stay safe on social 
networking plaƞorms. Always be careful, kind, and respecƞul online. 

 

This content provides an introducƟon to important online concepts for Class 4 students, helping them 
navigate the internet safely and responsibly. Let me know if you need further details or more exercises! 

 

             ***************************** 
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